XPL SEARCH - Search Exploits/Vulnerabilities In Multiple Databases Online

XPL SEARCH is a multiplatform tool( and Linux), which was developed in PHP with the aim of helping the hacker community to find exploits or 216;vulnerabilities217;, using .

Below is the of databases which can be used in this release:

  • Exploit-DB
  • MIlw00rm
  • PacketStormSecurity
  • IntelligentExploit
  • IEDB
  • CVE
  • Siph0n

The tool offers several options, such as:

  • Search individual.
  • Search with multiple words(list).
  • Select which databases will be used for research.
  • Filter to remove repeatable results.
  • Blocking specific databases.
  • Save log with the survey data.
  • Save the exploits/vulnerabilities found.
  • Use of proxy.
  • Set the time that the databases have to answer.
  • Conduct research just indicating the author’s name.
  • Disable display of the banner.

To use all the features as the tool provides, the following is recommended:
  • PHP Version(cli)     5.5.8 or higher
  • php5-cli                   Lib
  • cURL           Enabled
  • php5-curl                  Lib
  • cURL Version          7.40.0 or higher
  • allow_url_fopen      On
  • Permission               Writing & Reading

Dependencies necessary:

  • php5
  • php5-cli
  • php5-curl
  • curl
  • libcurl3

If you are unsure if the dependencies are installed, run the following command(Only for Linux):

php "xpl search.php" --install-dependencie

Or run in terminal:

sudo apt-get install php5 php5-cli php5-curl curl libcurl3

Usage:

php xpl_search.php [command] [term]

Example:

php xpl_search.php --search WordPress

Screenshots:



Source link

thanks you RSS link
( http://feedproxy.google.com/~r/EffectHacking/~3/IzBS8NRg4UQ/xpl-search.html)

LEAVE A REPLY

Please enter your comment!
Please enter your name here